PowerShell 6 and 7 Support

PowerShell 6 and 7 support is available if you have either of the environments installed. PowerShell Pro Tools will automatically locate the pwsh.exe that is required.

Selecting PowerShell 6 or 7

You can use the General options page of PowerShell Tools to select PowerShell 6 or 7.

You can also use the PowerShell Tools toolbar PowerShell Version combo box to select the PowerShell version. You can enable the toolbar by right clicking on the Visual Studio toolbar and then select PowerShell Tools.